网络协议分析
课题名称:网络协议分析
指导教师:赵红敏
专业班级:2014级计算机科学与技术2班学号: 20144591 姓名:孙晓阳
目录
实验一点到点协议PPP (4)
实验目的 (4)
实验环境 (4)
实验步骤 (4)
实验二地址转换协议ARP (10)
实验目的 (10)
实验环境 (10)
实验步骤 (10)
实验三Internet控制报文协议ICMP (16)
实验目的 (16)
实验环境 (16)
实验步骤 (16)
实验四实现”洞”的算法 (20)
实验目的 (20)
实验环境 (20)
实验要求 (20)
实验一点到点协议PPP
实验目的
1.理解PPP协议的工作原理及作用。
2.练习PPP,CHAP的配置。
3.验证PPP,CHAP的工作原理。
实验环境
1.安装windows操作系统的PC计算机。
2.Boson NetSim模拟仿真软件。
实验步骤
1、绘制实验拓扑图
利用Boson Network Designer绘制实验网络拓扑图如图1-1。
本实验选择两台4500型号的路由器。同时,采用Serial串行方式连接两台路由器,并选择点到点类型。其中DCE端可以任意选择,对于DCE端路由器的接口(Serial 0/0)需要配置时钟信号(这里用R1的Serial 0/0作为DCE端)。
2、配置路由器基本参数
绘制完实验拓扑图后,可将其保存并装入Boson NetSim中开始试验配置。配置时点击
Boson NetSim程序工具栏按钮eRouters,选择R1 并按下面的过程进行路由器1的基本参数配置:
Router>enable
Router#conf t
Router(config)#host R1
R1(config)#enable secret c1
R1(config)#line vty 0 4
R1(config-line)#password c2
R1(config-line)#interface serial 0/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#end
R1#copy running-config startup-config
点击工具栏按钮eRouters,选择R2并按下面过程进行路由器的基本参数配置:
Router>enable
Router#conf t
Router(config)#host R2
R2(config)#enable secret c1
R2(config)#line vty 0 4
R2(config-line)#password c2
R2(config-line)#interface serial 0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.0 R2(config-if)#no shutdown
R2(config-if)#end
R2#copy running-config startup-config
3、配置、测试PPP
选择路由器R1并配置PPP,如下所示:
R1#conf t
R1(config)#interface serial 0/0
R1(config-if)#encapsulation ppp
R1(config-if)#end
R1#copy running-config startup-config
选择路由器R2并配置PPP,如下所示:
R2#conf t
R2(config)#interface serial 0/0
R2(config-if)#encapsulation ppp
R2(config-if)#end
R2#copy running-config startup-config
选择路由器R1,按照下面的步骤测试并观察PPP诊断输出:R1# ping 192.168.0.2
R1#debug ppp negotiation
R1#conf t
R1(config)#interface serial 0/0
R1(config-if)# shutdown
R1(config-if)#no shutdown
R1(config-if)#end
R1#undebug all
4、配置、测试CHAP
选择路由器R1并配置CHAP,如下所示:
R1#conf t
R1(config)#username R2 password samepwd
R1(config)# interface serial 0/0
R1(config-if)#ppp authentication chap
R1(config-if)#end
R1#copy running-config startup-config
选择路由器R2并配置CHAP,如下所示:
R2#conf t
R2(config)#username R1 password samepwd
R2(config)# interface serial 0/0
R2(config-if)#ppp authentication chap
R2(config-if)#end
R2#copy running-config startup-config
选择路由器R1,按照下面步骤测试并观察CHAP配置: