BGP-4路由协议:
9.4.1 验证BGP基本功能
9.4.2 验证BGP报文信息正常发布和接收
9.4.3 验证BGP路由发布(network、静态、缺省) 9.4.4 验证BGP与IGP交互
9.4.5 BGP的路由聚合
9.4.6 BGP as-path的使用
9.4.7 BGP route-policy的使用
9.4.8 BGP路由反射器互通性测试
9.4.9 验证BGP负载分担和MED属性
9.4.10 BGP路由表容量测试
验证BGP基本功能
测试组网图:
测试步骤和结果:
步骤2:配置R1/R2/R3/R4/R5/R6的IGP路由
在R1上:interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip ospf 1 area 0
interface Ethernet1/0
ip address 172.16.1.5 255.255.255.252 ip ospf 1 area 0
interface Ethernet1/1
ip address 172.16.1.1 255.255.255.252 ip ospf 1 area 0
在R2上:interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
ip ospf 1 area 0
interface Ethernet1/0
ip address 172.16.1.6 255.255.255.252 ip ospf 1 area 0
interface Ethernet1/1
ip address 172.16.1.9 255.255.255.252
ip ospf 1 area 0
在R3上:interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
interface Ethernet1/0
ip address 172.16.1.2 255.255.255.252
ip ospf 1 area 0
interface Ethernet1/1
ip address 172.16.1.13 255.255.255.252 router ospf 1
passive-interface E1/1
在R4上:interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 1 area 0
interface Ethernet1/0
ip address 172.16.1.10 255.255.255.252
ip ospf 1 area 0
interface Ethernet1/1
ip address 172.16.1.17 255.255.255.252
ip ospf 1 area 0
router ospf 1
passive-interface E1/1
在R5上:
interface Loopback0
ip address 5.5.5.5 255.255.255.255
interface FastEthernet0/0
ip address 172.16.5.1 255.255.255.0 interface Ethernet1/0
ip address 172.16.1.14 255.255.255.252
在R6上:interface Loopback0
ip address 6.6.6.6 255.255.255.255
interface FastEthernet0/0
ip address 172.16.4.1 255.255.255.0 interface Ethernet1/0
ip address 172.16.1.18 255.255.255.252
步骤3:配置R1/R2/R3/R4/R5/R6的BGP邻居关系R1上:
router bgp 65000
no synchronization
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
neighbor 4.4.4.4 remote-as 65000
neighbor 4.4.4.4 update-source Loopback0 no auto-summary
在R2上:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0 neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0 neighbor 4.4.4.4 remote-as 65000
neighbor 4.4.4.4 update-source Loopback0 no auto-summary
在R3上:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0 neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback0 neighbor 4.4.4.4 remote-as 65000
neighbor 4.4.4.4 update-source Loopback0 neighbor 172.16.1.14 remote-as 65001
no auto-summary
在R4上:router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0 neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback0 neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0 neighbor 172.16.1.18 remote-as 65002
no auto-summary
在R5上:
router bgp 65001
no synchronization
neighbor 172.16.1.13 remote-as 65000
no auto-summary
在R6上:
router bgp 65002
no synchronization
neighbor 172.16.1.17 remote-as 65000
no auto-summary